TestGorilla - Some Candidates Unable to Complete Assessments – Incident details

All systems operational

Some Candidates Unable to Complete Assessments

Resolved
Degraded performance
Started 3 months agoLasted less than a minute

Affected

Assessments (new) - talent-assessment.testgorilla.com

Operational from 1:40 PM to 1:40 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    We experienced an issue on September 4, 2025, where some candidates were unable to complete their assessments due to a problem with the Finish button. The issue has been identified and resolved, and system behavior has returned to normal.

    We are reviewing affected sessions and will follow up with impacted candidates.